Thứ Tư, 3 tháng 7, 2013

Hướng dẫn cấu hình Inter Vlan Routing full

INTER - VLAN ROUTING


Mỗi Vlan là một miền Broadcast với các subnet khác nhau, nên các Vlan này không thể truyền thông với nhau được. Một cách để các Vlan có thể truyền thông với nhau, đó là: Inter-Vlan Routing.
Có 3 cách cấu hình Inter-Vlan Routing:
+ C1: One-Router-Interface-per-Vlan hay còn gọi là Traditional inter-routing vlan. 
Phương pháp thực hiện bằng cách kết nối các giao diện vật lý của Router với các giao diện vật lý của Switch (switch port). Các switch ports kết nối với Router ở chế độ access mode (static mode). Mỗi giao diện switch được chia đến static Vlan khác nhau, switch kết nối với PC cũng ở chế độ access mode. Các giao diện vật lý trên Router cũng được chia địa chỉ IP và subnet mask như bình thường.
Phương pháp traditional inter-vlan routing có đặc điểm là: hạn chế về số lượng giao diện vật lý khi số lượng vlan tăng lên do vậy phương pháp này không được phổ biến khi sử dụng ở mạng lớn. 

C2:Cấu hình Router-on-a-stick: trên 1 kết nối Trunk, định tuyến giữa các vlan khác nhau. Cấu hình Router định tuyến inter-vlan bằng phương pháp này khi kết nối giữa Switch port và giao diện Router là Trunk. Vì vậy, Switch phải cấu hình Trunk. Đây là phương pháp cấu hình định tuyến giữa các Vlan trên một giao diện vật lý của Router. Trên giao diện vật lý của Router cấu hình subinterface cho từng vlan. Phương pháp này có đặc điểm tiết kiệm được giao diện vật lý sử dụng so với phương pháp traditional vlan.
Khi đó trình tự cấu hình trên Router như sau:
- Cấu hình trunk trên switch kết nối với router, cấu hình access mode ở kết nối với PC
- Cấu hình Subinterfaces trên Router: Subinterface là giao diện ảo được kết nối với giao diện vật lý. Những subinterfaces được cấu hình như phần mềm trên router và được chia địa chỉ IP độc lập phụ thuộc vào từng vlan được chia cho subinterface đó. No shut down hay shut down trên giao diện vật lý cũng có tác dụng với subinterface.
R(config)#interface interface-id.subinterface-id
R(config-subif)#encapsulation dot1q vlan-id
R(config-subif)#ip address ip-address subnet-mash
R(config-subif)#interface interface-id
R(config-if)#no shutdown

Định tuyến bằng Switch Layer 3
Switch Layer 3 có khả năng định tuyến giữa các VLan khác nhau. Nó sử dụng SVI như một giao diện router để định tuyến dữ liệu giữa các Vlan, mỗi Vlan được xác định bởi một giá trị SVI (switch virtual interface). 
So sánh Switch layer 3 với Router.
Feature
Switch layer 3
Router
Layer 3 routing
Support
Support
Traffic management
Support
Support
WIC support

Support
Advanced routing protocols

Support
Wirespeed routing
Support

Kiểm tra
R#show ip route

Làm thế nào để cấu hình Inter VLAN Routing


Giới thiệu:

VLAN được định nghĩa là một mạng ảo địa phương hoặc mạng LAN ảo. VLAN được sử dụng để phân chia lĩnh vực phát sóng của một chuyển đổi. Theo mặc định, một switch có nhiều collision domains và một vùng broadcast domain

 

Có hai loại của VLAN, đó là:

Static VLAN

Dynamic VLAN

VTP ( VLAN Trucking Protocol )

 

Nó là một giao thức độc quyền của Cisco. Nó được sử dụng để quản lý các thông tin liên lạc liên VLAN vào mạng. Sử dụng VTP chúng ta có thể tạo, xóa và sửa đổi mạng. VTP mang thông tin VLAN cho tất cả các thiết bị chuyển mạch trong một miền VTP. Nó hoạt động với ISL, 802.1q, và IEEE 802,10.

 

Inter-VLAN Routering

Theo mặc định một VLAN không thể giao tiếp với một VLAN. Để tạo trao đổi liên VLAN, chúng ta cần một thiết bị L3 giống như một router hoặc switch L3. Để tạo liên VLAN, chúng ta cần làm một cổng trunk. Tất cả các trao đổi VLAN được thực hiện với cổng trunk này.

 

Trên router, chúng tta tạo ra một sub-interface trên router được kết nối với các cổng trunk của switch. Tất cả sun interface được cấu hình với một số kỹ thuật đóng gói như ISL hoặc IEEE 802.1q.

 

Ví dụ

Trong mạng lưới này, chúng ta có một switch (L2 switch). Trong chuyển đổi này, chúng ta tạo ra hai hình VLAN, VLAN 2 và VLAN 3. VLAN 2 có hai máy tính và có mạng 192.168.1.0. VLAN 3 có ba máy vi tính và mạng 192.168.2.0.

 VirtualLAN.jpg

Config Switch








Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname IT
IT(config)#enable secret admin
IT(config)#enable secret ?

0      Specifies an UNENCRYPTED password will follow
5      Specifies an ENCRYPTED secret will follow
LINE   The UNENCRYPTED (cleartext) 'enable' secret
level  Set exec level password

IT(config)#vlan 2
IT(config-vlan)#name it
IT(config-vlan)#exit

IT(config)#vlan 3
IT(config-vlan)#name hr
IT(config-vlan)#exit

IT(config)#interface fastEthernet 0/2
IT(config-if)#switchport mode access
IT(config-if)#switchport access vlan 2
IT(config-if)#exit

IT(config)#interface fastEthernet 0/3
IT(config-if)#switchport mode access
IT(config-if)#switchport access vlan 2
IT(config-if)#exit

IT(config)#interface fastEthernet 0/11
IT(config-if)#switchport mode access
IT(config-if)#switchport access vlan 3
IT(config-if)#exit

IT(config)#interface fastEthernet 0/12
IT(config-if)#switchport mode access
IT(config-if)#switchport access vlan 3
IT(config-if)#exit

IT(config)#interface fastEthernet 0/13
IT(config-if)#switchport mode access
IT(config-if)#switchport access vlan 3
IT(config-if)#exit

IT(config)#interface vlan 2
IT(config-if)#ip address 192.168.1.1 255.255.255.0
IT(config-if)#no shutdown
IT(config-if)#exit


IT(config)#interface vlan 3

%LINK-5-CHANGED: Interface Vlan3, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan3, changed state to up

IT(config-if)#ip address 192.168.2.1 255.255.255.0
IT(config-if)#no shutdown
IT(config-if)#exit


IT(config)#interface fa
IT(config)#interface fastEthernet 0/1
IT(config-if)#shutdown


%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down



IT(config-if)#interface fastEthernet 0/1
IT(config-if)#switchport mode access
IT(config-if)#switchport mode trunk

 Configuration of Router






Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fastEthernet 0/0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up


Router(config-if)#interface fastEthernet 0/0.1

%LINK-5-CHANGED: Interface FastEthernet0/0.1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.1, changed state to up


Router(config-subif)#encapsulation dot1Q 1
Router(config-subif)#ip address 192.168.1.1 255.255.255.0
Router(config-subif)#no shutdown
Router(config-subif)#exit


Router(config)#interface fastEthernet 0/0.2

%LINK-5-CHANGED: Interface FastEthernet0/0.2, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.2, changed state to up


Router(config-subif)#encapsulation dot1Q 2
Router(config-subif)#ip address 192.168.2.1 255.255.255.0
Router(config-subif)#no shutdown

 Hiển thị tất cả những gì vừa config VLAN trên switch

 ShowVLAN.jpg

 

Hiển thị tất cả những gì vừa config Router interface

 InterVLANCommunication.jpg

 

Hiển thị tất cả các interface của switch

 SwitchInterface.jpg

 

Hiển thị tất cả các interface của router

InterVlanRouting.jpg

0 nhận xét:

Đăng nhận xét