Thứ Năm, 3 tháng 10, 2013

Hướng dẫn Cấu hình Routing trên Switch Layer 3

Switch layer 2 chỉ hoạt động trên layer 2 của môt hình TCP/IP tức là nó xứa lý các frame dự trên các thông số của Frame, Với dòng switch layer 3 của cisco, ngoài các tính năng của một switch bình thường thì nó có tính năng nâng cao đó là routing và hoạt động giống như một Router, Switch layer 3 là một lựa chọn hoàn hảo cho những doanh nghiệp cần nhu cấu kết nối nhiều. Các Rouer có số lượng cổng kết nối hạn chế, còn với switch thì số cổng là rất lớn với dòng switch cao cấp của Cisco 6500 series số cổng mở rộng lên tới hơn 200 cổng như vây nó đáp ứng tốt cho nhu cầu kết nối. Hệ thống Internet cũng sử dụng loại switch đa lớp này để làm chuyển mạch, ngoài tính năng đa lớp nó còn cung cấp nhứng tính năng bảo mật tốt.
Như vậy để quản lý và vận hành hiểu quả hệ thống Switch layer 3 chúng ta cần phải nắm rõ nguyên lý của switch layer 2 vả của Router.
Ở bài này tôi sẽ hưỡng dận các bạn cấu hình Switch layer 3 đây là hưỡng dẫn cơ bản, và các bạn có thể áp dụng vào thực tế. Nếu các bạn còn chưa chắc chắn về kiển thức liên quan, mời các bạn tham khảo trên website này của tôi.
Tình huống đặt ra đối với doanh nghiệp như sau:


Công ty tôi có 60 máy tính và thuộc nhiều phong ban khắc nhau, phòng kế toán của tôi có 10 máy, phong nhân sự có 20 máy, phong kinh doanh có 30 máy. Một hôm giám đốc của tôi yêu cầu, phải thiết lập hệ thống mạng của các phong ban sao cho may tính của các phòng truy cập lấn nhau và internet ,đảm bảo hệ thống mạng luôn hoạt động tốt không bị gián đoạn và trong tương khi công ty mở rông không phải mua thêm thiết bị. các thiết bị của công ty hiện có 1 đường truyền internet tốc độ cao, 1 modem(1 cổng internet, 1 cổng lan), 3 switch 2960G - 24port. Và thực tại các máy tính của công ty đang sử dụng chung một VLAN.
Giả quyết yêu cầu của Giám đốc. 
    -Đầu tiên sẽ tạo mỗi phòng thuộc một VLAN khác nhau
  - Phải có một thiết bị định tuyển giứa các VLAN
   Nếu mua 1 Router dùng để định tuyên các VLAN thì cũng được nhưng chúng ta phải cấu hình sub-interface cho Router như vậy nêu khi công ty mở rộng nhiều VLAN thì chúng ta phải chia nhiều sub-interface cho Router như vậy dễ bị tình trạng thắt nút cổ chai tại Router.
 Nếu chúng ta mua một thiết bị Switch layer 3 thì sẽ định tuyến được các VLAN và trong tương lai khi công ty mở rộng thì chất lượng mạng vấn đảm bảo tốt.
Sau đây là mô hình lab của tôi.


  Modem có ip: 192.168.1.1
  interface F0/4 switch 3560 kết nối Modem có ip :192.168.1.2
 Vlan 2: ketoan   ip: 192.168.2.0/24   default-gateway: 192.168.2.1
 Vlan 3: nhansu    ip: 192.168.3.0/24  default-gateway: 192.168.3.1
 Vlan 4: kinhdoanh   ip: 192.168.4.0/24  default-gateway: 192.168.4.1
   Vlan 2: PC có ip : 192.168.2.2 
   Vlan 3: PC có ip : 192.168.3.2
   Vlan 4: PC có ip : 192.168.4.2
   interface f0/1 switch 1 kết nối f0/1  switch layer 3
   interface f02 switch 2 kết nối f0/2  switch layer 3
  interface f0/3 switch 3 kết nối f0/3  switch layer 3 
Chúng ta bắt đầu cấu hình:

Bước 1: Cấu hình Switch layer 3.
 - Mặc định tất cả các cổng của swtich hoạt động ở layer 2, để có thể đặt được ip chúng ta disable mode switch của interface chúng ta muốn đặt ip trong bài lab này là Interface: F0/4
3560(config)#interface f0/4
3560(config-if)#no switchport 

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up
3560(config-if)#ip address 192.168.1.1 255.255.255.0
3560(config-if)#no shutdown
3560(config-if)#exit
3560(config)# 

 - Cấu hình Vlan:
 3560#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
3560(config)#vlan 2
3560(config-vlan)#name ketoan
3560(config-vlan)#exit
3560(config)#vlan 3
3560(config-vlan)#name nhansu
3560(config-vlan)#exit
3560(config)#vlan 4
3560(config-vlan)#name kinhdoanh
3560(config-vlan)#exit
3560(config)#
- Cấu hình interface VLAN

3560(config)#inter vlan 2
3560(config-if)#ip address 192.168.2.1 255.255.255.0
3560(config-if)#no shutdown
3560(config-if)#exit
3560(config)#int vlan 3
3560(config-if)#ip address 192.168.3.1 255.255.255.0
3560(config-if)#no shutdown
3560(config-if)#exit
3560(config)#int vlan 4
3560(config-if)#ip address 192.168.4.1 255.255.255.0
560(config-if)#no shutdown
3560(config-if)#exit
3560(config)#
 

- Cấu hình gán Vlan tương ứng tới inerface tương ứng
 3560(config)#int f0/1
3560(config-if)#switchport access vlan 2
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2, changed state to up
3560(config-if)#
3560(config-if)#exit
3560(config)#interface f0/2
3560(config-if)#switchport access vlan 3
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan3, changed state to up
3560(config-if)#exit
3560(config)#int f0/3
3560(config-if)#switchport access vlan 4
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan4, changed state to up
3560(config-if)#exit
3560(config)#
-Cấu hình routing
   Để kích hoạt tính năng Routing trên switch layer 3 chúng ta chỉ cần dùng câu lệnh:
    3560(config)#ip routing

- Kiểm tra Vlan
 3560#show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/4, Fa0/5, Fa0/6, Fa0/7
                                                Fa0/8, Fa0/9, Fa0/10, Fa0/11
                                                Fa0/12, Fa0/13, Fa0/14, Fa0/15
                                                Fa0/16, Fa0/17, Fa0/18, Fa0/19
                                                Fa0/20, Fa0/21, Fa0/22, Fa0/23
                                                Fa0/24, Gig0/1, Gig0/2
2    ketoan                           active    Fa0/1
3    nhansu                           active    Fa0/2
4    kinhdoanh                        active    Fa0/3
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    
3560#

-Kiểm tra Bảng định tuyến
3560#sho ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, FastEthernet0/4
C    192.168.2.0/24 is directly connected, Vlan2
C    192.168.3.0/24 is directly connected, Vlan3
C    192.168.4.0/24 is directly connected, Vlan4
3560#

Như vậy chúng ta đã cấu hình thành công Switch layer 3 để định tuyến giữa  các phòng trong công ty, nhưng chỉ dừng lại ở đây thì các máy tính chưa thể truy cập được internet bới switch layer 3 khi nhận được packet đi internet nó chưa biết chuyển đi đâu kết quả là gói tin đó sẽ bị drop. Đơn gián thôi giờ chúng ta sẽ cấu hình một tuyến default-ruote tới modem và trên modem chúng ta cũng add thêm một route để trỏ vào mạng bên trong.
3560(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1
Và bảng định tuyến của chúng ta bây giờ sẽ có thêm một tuyến S*
3560#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

C    192.168.1.0/24 is directly connected, FastEthernet0/4
C    192.168.2.0/24 is directly connected, Vlan2
C    192.168.3.0/24 is directly connected, Vlan3
C    192.168.4.0/24 is directly connected, Vlan4
S*   0.0.0.0/0 [1/0] via 192.168.1.1
3560#
 


Bước 2: Cấu hình PC và kiểm tra 
  Cấu hình địa chỉ ip cho các máy tính theo thông tin ở trên.
Sau khi đã cấu hình xong PC chúng ta tiến hành kiểm tra xem các máy tính ở các vlan đã kết nối được với nhau chưa bằng cách ping
Chức các bạn nghiên cứu tốt !

0 nhận xét:

Đăng nhận xét