Thứ Hai, 10 tháng 6, 2013

Tìm hiểu về STATIC ROUTING

Lý thuyết về Static Routing

1. Static Routing:
1.1. Static Routing là gì ?
Định tuyến tĩnh (Static Routing) là người quản trị mạng phải nhập các thông tin về đường đi cho router. Khi cấu trúc mạng có xảy ra bất kỳ sự thay đổi nào thì chính người quản trị mạng phải xóa hoặc thêm các thông tin về đường đi cho router. Đường đi như vậy được gọi là đường cố định. Đối với hệ thống mạng lớn thì công việc bảo trì bảng định tuyến cho router như vậy tốn rất nhiều thời gian. Nhưng đối với hệ thống mạng nhỏ, ít có thay đổi thì công việc này đỡ mất công hơn. Chính vì định tuyến tĩnh đòi hỏi người quản trị phải cấu hình mọi thông tin về đường đi cho router nên nó không có tính linh hoạt như định tuyến động (Dynamic Routing). Trong những hệ thống mạng lớn, định tuyến tĩnh thường được sử dụng kết hợp với giao thức định tuyến động cho một số mục đích đặc biệt.

1.2. Hoạt Động của Static Routing :
Hoạt động của định tuyến tĩnh có thể chia ra làm 3 bước sau:
-Đầu tiên, người quản trị mạng phải cấu hình các đường cố định cho router.
-Router cài đặt các đường đi này vào bảng định tuyến.
-Gói dữ liệu được định tuyến theo các đường cố định.
1.3. Cấu hình đường cố định :
Static Routing được cấu hình bằng tay bằng câu lệnh ip route
Câu lệnh ip route có thể thiết lập router tiếp theo bằng hai cách sau:
+ Giao diện đi ra (cổng đi ra).

+ Địa chỉ IP của router kế cận.

Ngoài ra, trong Static Routing có một trường hợp đặc biệt được gọi là Default Route. Câu lệnh tương tự như Static Routing nhưng địa chỉ mạng đích và subnet mask là không cần biết. Đặc điểm của Default Route là:
+ Độ ưu tiên thấp nhất, nằm chót bảng định tuyến.
+ Không cần biết mạng đích nằm ở đâu và subnet mask là gì.
Ví dụ: R1(config)# ip route 0.0.0.0 0.0.0.0 s1/0
hoặc R1(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.2

Lab

Giả sử ta có mô hình như hình trên.
Để định tuyến 3 router trên bằng Static Routing, ta làm như sau:

Đối với router R1: (ta dùng outbound interface)
Router >en
Router # config terminal
Router (config) # hostname R1

R1 (config) # interface loopback 0
R1 (config-if) # ip address 192.168.1.1 255.255.255.0
R1 (config-if) # exit

R1 (config) # interface s1/0
R1 (config-if) # ip address 192.168.12.1 255.255.255.0
R1 (config-if) # no shutdown
R1 (config-if) # exit

R1 (config) # ip route 192.168.2.0 255.255.255.0 s1/0
R1 (config) # ip route 192.168.23.0 255.255.255.0 s1/0
R1 (config) # ip route 192.168.3.0 255.255.255.0 s1/0

Đối với router R2: (ta dùng next hope)
Router >en
Router # config terminal
Router (config) # hostname R2

R2 (config) # interface loopback 0
R2 (config-if) # ip address 192.168.2.1 255.255.255.0
R2 (config-if) # exit

R2 (config) # interface s1/0
R2 (config-if) # ip address 192.168.12.2 255.255.255.0
R2 (config-if) # no shutdown
R2 (config-if) # exit

R2 (config) # interface s1/1
R2 (config-if) # ip address 192.168.23.2 255.255.255.0
R2 (config-if) # no shutdown
R2 (config-if) # exit

R2(config) # ip route 192.168.1.0 255.255.255.0 192.168.12.1
R2(config) # ip route 192.168.3.0 255.255.255.0 192.168.23.3

Đối với router R3: (ta dùng default route)
Router >en
Router # config terminal
Router (config) # hostname R3

R3(config) # interface loopback 0
R3(config-if) # ip address 192.168.3.1 255.255.255.0
R3(config-if) # exit

R3(config) # interface s1/0
R3(config-if) # ip address 192.168.23.3 255.255.255.0
R3(config-if) # no shutdown
R3(config-if) # exit

R3(config) # ip route 0.0.0.0 0.0.0.0 s1/0

Xong việc cấu hình cho 3 router. Để kiểm tra các mạng có thể thấy nhau hay không, ta có thể dùng lệnh “ping” để kiểm tra hoặc dùng lệnh “show ip route” để kiểm tra bảng định tuyến của các router.

0 nhận xét:

Đăng nhận xét