Thứ Năm, 27 tháng 6, 2013

Kỹ thuật DHCP ARP spoofing attack trên switch

SCENARIO #1: TẤN CÔNG DHCP DISCOVER, XIN HẾT IP CỦA DHCP SERVER.

I – CHUẨN BỊ:

- Kết nối các thiết bị như mô hình dưới đây:

- Tắt tính năng tự cấp DHCP khi PC giả lập dùng Host-Only bằng cách vào Edit /Virtual Network Editor, chọn card Vmnetx(1,2,3…) Host-Only sau đó bỏ chọn “Use local DHCP service …”, lúc này ko cần đến VMware cấp DHCP để phù h với mô hình lab. 

R1:

Dùng Router 3725.

<int fa0/0
ip address 192.168.10.254
no shut
ip dhcp pool bao
network 192.168.10.0
default-router 192.168.10.254>

SW:

Dùng Router 3725 add thêm Slot 16ESW đễ giả lập SW, khi kết nối thì chỉ dùng các cổng f1/0 trở đi (ko dùng các cổng f0/x).

Máy Linux BackTrack4:

- Cấu hình trong VMware là Network Adapter là Custom: Vmnet1(Host-Only).

- <vim /etc/network/interfaces> chỉnh lại để nhận DHCP, nhớ <update-rc.d networking defaults> và </etc/init.d/networking restart> để cập nhật cấu hình.

- Trong GNS3 thì click vào máy Linux, chọn Configure, chọn card Vmnet1(Host-Only).

- Trên máy thật nhớ enable card VMnet1(Host-Only).

- </etc/init.d/networking restart> để xin Ip động từ DHCP.

Máy Windows:

- Dùng PC thật nhưng disable card Lan và Enable card loopback, card loopback chỉnh để tự nhận IP từ DHCP.

- Trong GNS3 thì click vào máy Windows, chọn Configure, chọn card Loopback.

- ipconfig /release và ipconfig /renew để xem WIndows có dc cấp Ip từ DHCP ko.

R3:

<int fa0/0
no shut
ip address dhcp>

Nếu thấy được cấp IP thuôc mạng 192.168.10.0/24 là OK.

R1:

<sh ip dhcp bind> nếu thấy cấp đủ IP cho các Host là OK.

II – TIẾN HÀNH:

- Default thì Yersinia được cài sẵn trên cả BackTrack(BT) 4 và 5, tuy nhiên BT4 hoạt đông tốt nhất, BT5 thì bị lỗi (cho BT 5 R2 và R3).

- Trên máy BT4 gõ: <yersinia -I> (hay yersinia -G)

- F2 để tấn công DHCP mode, nhấn X để bắt đầu tấn công (xin hết IP của DHCP Server), nhấn 1 để chọn No1.sending Disconver packet.

- Lúc này R1 <sh ip dhcp binding> sẽ thấy tất cả IP đã dc cấp, do đó Client hợp lệ ko thể xin dc IP nữa.

- R1 gõ <clear ip dhcp pool bao binding *> để xóa những IP đã cấp.

 

SCENARIO #2: TẤN CÔNG GIẢ MẠO, CẤP IP VÀ GW GIẢ CHO CLIENT.

I – CHUẨN BỊ:

Giữ nguyên sơ đồ trên.

II – TIẾN HÀNH:

- Máy BT4 gõ <ettercap -G>

- Chọn Sniff, chọn Unified sniffing…, chọn card eth0, click OK.

 

SCENARIO #3: TẤN CÔNG ARP POISONING.

I – CHUẨN BỊ:

Giữ nguyên sơ đồ trên.

II – TIẾN HÀNH:

 

SCENARIO #4: TẤN CÔNG IP SPOOFING QUA SWITCH.

I – CHUẨN BỊ:

R2 dùng Router 3725 slot 16ESW để giả lập SW.

Hacker dùng BT4(VMnet1(Host-Only)), Victim dùng máy thật Windows 7(Loopback).

Đảm bảo ping thấy nhau.

II – TIẾN HÀNH:

- Trên BT4 gõ <nmap -e eth0 -S 192.168.200.200 -PN 192.168.10.10>

- Trong đó: 192.168.200.200 là fake IP, 192.168.10.10 là IP victim_Windows, -e eth0 là card mạng Hacker BT4 đang dùng.

- Sau khi Nmap xong thì máy Victim_windows mở Wireshark để capture(Loopback) hoặc nhanh hơn và OK hơn là trên GNS3 click phải vào đoạn mạng chỗ giữa Victim_Windows và SW rồi chọn capture.

- Lúc này sẽ thấy Source.IP là 192.168.200.200 (chứ không phải 192.168.10.20 của Hacker)và Dest.IP là 192.168.10.10 là OK.

SCENARIO #5: TẤN CÔNG IP SPOOFING QUA ROUTER.

Trên máy Hacker hay Victim đều có thêm việc trỏ GW về cổng của Router, ví dụ: Victim trỏ GW về 192.168.9.15, Hacker_BT trỏ GW về 192.168.10.15.

Đảm bảo 2 PC ping thấy nhau.

Hacker BT4 dùng Nmap <nmap -e eth0 -S 192.168.200.200 -PN 192.168.9.10>

Lúc này bên máy Victim_Windows mở Wireshark (hoặc capture đoạn mạng giữa Victim_Windows với Router trên GNS3) sẽ thấy IP là 192.168.200.200 và 192.168.9.10.

Tiếp theo, trên R2 ta tạo access-list cấm IP của Hacker trên interface f1/2:

R(config)#access-list 1 deny host 192.168.10.20

R(config)#access-list 1 permit any

R(config)#int f1/2

R(config)#ip access-group 1 in

2-34.jpg

XONG !!!!!!!!!!!!!!!

0 nhận xét:

Đăng nhận xét