Thứ Năm, 27 tháng 6, 2013

Hướng dẫn cấu hình VLAN trunking vtp (VLAN trunking protocal)

I. Giới thiệu
- VLAN là cách thức cho phép chúng ta đưa một nhóm các máy tính có cùng tiêu chí: chức năng, vị trí địa lý vào một subnet riêng để nâng cao hiệu quả hoạt động của mạng, quản lý mạng, …
- Trunk cho phép chung ta truyền tải thông tin của nhiều VLAN trên một kết nối, nếu các kết nối mà không được Trunk thì chúng chỉ cho thông tin vủa một VLAN được truyền tải qua đó

- VTP là giao thức hoạt động ở Layer 2 trong mô hình OSI. VTP giúp cho việc cấu hình VLAN luôn đồng nhất khi thêm, xóa, sửa thông tin về VLAN trong hệ thống mạng.

- VTP flood thông điệp quảng bá (advertisement) qua VTP domain 5 phút một lần, hoặc khi có sự thay đổi xảy ra trong cấu hình VLAN. Một VTP advertisement bao gồm có rivision-number, tên VLAN (vlan name), số hiệu VLAN (vlan number), và thông tin về các switch có port gắn với mỗi VLAN. Bằng sự cấu hình VTP Server và việc truyền bá thông tin thông qua các advertisement, tất cả các switch đều biết về tên VLAN và số hiệu VLAN của tất cả các VLAN.

- Một trong những thành phần quan trọng của VTP advertisement là tham số revision number. Mỗi lần VTP server điều chỉnh thông tin VLAN, nó tăng revision-number lên 1, rồi sau đó VTP Server mới gửi VTP advertisement đi. Khi một switch nhận một VTP advertisement với revision-number lớn hơn, nó sẽ cập nhật cấu hình VLAN.


II. Mô hình


 

III. Yêu cầu
1. Cấu hình khởi tạo cho các thiết bị mạng.
- Đặt tên
- Cấu hình Banner motd
- Cấu hình IP Address managerment
- Cấu hình password cho console, telnet, Privileged.
Password console: itn
Password telnet: itn
Password Privileged: itn
2. Cấu hình

- VLAN 2: kế toán
- VLAN 3: kinh doanh
Trên SW1:
VLAN 2: các port từ Fa0/1 – Fa0/10
VLAN 3: các Interface từ F0/11 – 24
Trên Sw2:
VLAN 2: Các interface từ F0/1 – 16
VLAN 3: Các interface từ F0/17 – 24

IV. Cấu hình chi tiết
1. Cấu hình khởi tạo

1.1 Switch 1
Switch(config)#hostname Switch1
Switch1(config)#enable secret itn
Switch1(config)#banner motd ' switch server'
Switch1(config)#line console 0
Switch1(config-line)#password itn
Switch1(config-line)#login
Switch1(config-line)#exit

Switch1(config)#line vty 0 15
Switch1(config-line)#password itn
Switch1(config-line)#login
Switch1(config-line)#exit
// cấu hình địa chỉ IP quản lý, mặc định tất cả các port của Switch là thuộc VLAN 1
Switch1(config)#interface vlan 1
Switch1(config-if)#ip add 192.168.1.1 255.255.255.0
Switch1(config-if)#no shut

1.2 Switch 2
Switch(config)#hostname Switch2
Switch2(config)#enable secret itn
Switch2(config)#banner motd ' switch client'
Switch2(config)#line console 0
Switch2(config-line)#password itn
Switch2(config-line)#login
Switch2(config-line)#exit

Switch2(config)#line vty 0 15
Switch2(config-line)#password itn
Switch2(config-line)#login
Switch2(config-line)#exit

// cấu hình địa chỉ IP quản lý, mặc định tất cả các port của Switch là thuộc VLAN 1
Switch1(config)#interface vlan 1
Switch1(config-if)#ip add 192.168.1.1 255.255.255.0
Switch1(config-if)#no shut


2. Cấu hình
- Chúng ta thấy yêu cầu đầu bài đó là trên cả 2 Switch đều có thông tin của các VLAN tương tự nhau, tức là thông tin VLAN trên hai Switch là giống nhau, như vậy chúng phải có cùng database VLAN, để có thể triển khai được yêu cầu đó chúng ta phải cấu hình VTP trên Switch, giữa Sw1 và Sw2 có kết nối với nhau một interface, để thông tin của các VLAN có thể truyền tải qua kết nối đó thì kết nối giữa chúng phải được Trunk với nhau

- Các bước cấu hình khi triển khai
+ đầu tiên các bạn phải cấu hình VTP, Trunk
+ Tạo các VLAN trên Switch đóng vai trò là VTP Server
+ Gán các port của Switch vào các VLAN

2.1 Cấu hình VTP, Trunk

2.1.1 Cấu hình Switch 1
a. Cấu hình trunk.
Switch1(config)#int fastEthernet 0/1
Switch1(config-if)#switchport mode 
trunk


b. Cấu hình VTP, VLAN.
Switch1#conf t
Switch1(config)#vtp mode server 
//ở mode server Switch có thể tạo 

mới, chỉnh sửa, xoá thông tin của VLAN
Switch1(config)#vtp domain itn // tất cả các Switch phải cùng VTP Domain,
password mới chia sẻ được thông tin VLAN
Switch1(config)#vtp password cisco
Switch1(config)#vtp pruning


c. Kiểm tra cấu hình
+ Kiểm tra VTP

Switch1#show vtp status
VTP Version : 2
Configuration Revision : 20
Maximum VLANs supported locally : 250
Number of existing VLANs : 8
VTP Operating Mode : Server
VTP Domain Name : itn
VTP Pruning Mode : Enabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0x18 0xC7 0x05 0x84 0x7E 0x67 0xEA 0xD1
Configuration last modified by 0.0.0.0 at 3-1-93 0054
Local updater ID is 0.0.0.0 (no valid interface found

+ Kiểm tra Interface Trunk
Switch1#sh int trunk
Port Mode Encapsulation Status Native vlan
Fa0/1 on 802.1q trunking 1


Port Vlans allowed on trunk
Fa0/1 1-1005

Port Vlans allowed and active in management domain
Fa0/1 1

Port Vlans in spanning tree forwarding state and not pruned
Fa0/1 1

2.1.2 Cấu hình Switch 2
d. Cấu hình trunk.

Switch1(config)#int fastEthernet 0/1
Switch1(config-if)#switchport mode trunk

e. Cấu hình VTP, VLAN.
Switch2#conf t
Switch2(config)#vtp mode server 
//ở mode client Switch cập nhật thông tin 

VLAN từ Switch Server và các Switch khác 
Switch2(config)#vtp domain itn
Switch2(config)#vtp password cisco
Switch1(config)#vtp pruning

f. Kiểm tra cấu hình VTP 
SWitch2#show vtp status
VTP Version : 2
Configuration Revision : 20
Maximum VLANs supported locally : 250
Number of existing VLANs : 8
VTP Operating Mode : Client
VTP Domain Name : itn
VTP Pruning Mode : Enabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0x18 0xC7 0x05 0x84 0x7E 0x67 0xEA 0xD1
Configuration last modified by 0.0.0.0 at 3-1-93 0054

+ Kiêm tra Interface Trunk
Switch2#show interfaces trunk
Port Mode Encapsulation Status Native vlan
Fa0/1 on 802.1q trunking 1


Port Vlans allowed on trunk
Fa0/1 1-1005

Port Vlans allowed and active in management domain
Fa0/1 1

Port Vlans in spanning tree forwarding state and not pruned
Fa0/1 none

// Sau khi kiểm tra cấu hình VTP, Trunk các bạn thây thông tin về domain, mode, interface trunk đã đúng chúng ta chuyển sang bước tiếp theo

2.2 Cấu hình tạo VLAN trên Switch VTP Server

2.2.1 Cấu hình tào các VLAN
Switch1(config)#vlan 2
Switch1(config-vlan)#name ketoan


Switch1(config)#vlan 3
Switch1(config-vlan)#name kinhdoanh

2.2.2 Kiểm tra thông tin VLAN đã đồng nhất chưa
g. Trên Switch 1

Switch1#show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/2, Fa0/3, Fa0/4, Fa0/5
Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10, Fa0/11, Fa0/12, Fa0/13
Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/19, Fa0/20, Fa0/21
Fa0/22, Fa0/23, Fa0/24, Gi0/1
Gi0/2
2 keotan active
3 kinhdoanh active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
30 enet 100030 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - srb 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

h. Trên Switch 2
SWitch2#show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/2, Fa0/3, Fa0/4, Fa0/5
Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10, Fa0/11, Fa0/12, Fa0/13
Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/19, Fa0/20, Fa0/21
Fa0/22, Fa0/23, Fa0/24, Gi0/1
Gi0/2
2 ketoan active
3 kinhdoanh active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
30 enet 100030 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - srb 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

// Câu lệnh show vlan trên các Switch như trên đã cho ta biết thông tin VLAN trên hai Switch đã được đồng nhất, lúc này chúng ta mới chuyển sang bước tiếp theo

2.3 Gán các Interface vào các VLAN theo yêu cầu
2.3.1 Cấu hình trên switch 1

Switch1(config)#int range fastEthernet 0/1 - 10
Switch1(config-if-range)#switchport mode access
Switch1(config-if-range)#switchport access vlan 2


Switch1(config)#int range fastEthernet 0/11 – 24
Switch1(config-if-range)#switchport mode access
Switch1(config-if-range)#switchport access vlan 3

2.3.2 Cấu hình trên Switch 2
Switch1(config)#int range fastEthernet 0/1 - 16
Switch1(config-if-range)#switchport mode access
Switch1(config-if-range)#switchport access vlan 2


Switch1(config)#int range fastEthernet 0/17 – 24
Switch1(config-if-range)#switchport mode access
Switch1(config-if-range)#switchport access vlan 3

3. Kiểm tra cấu hình
3.1.1 Kiểm tra trên Switch 1

Switch1#show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi0/1, Gi0/2
2 ketoan active Fa0/2, F0/3, F0/4, F0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, F0/10
3 kinhdoanh active Fa0/11, Fa0/12, Fa0/13, Fa0/13, F0/14, F0/15
Fa0/16, F0/17, F0/18, F0/19, F0/20, F0/21, F0,22
F0/23, F0,24
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
30 enet 100030 1500 - - - - - 0 0

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - srb 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

3.1.2 Kiểm tra trên Switch 2
Switch2#show vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi0/1, Gi0/2
2 ketoan active Fa0/2, F0/3, F0/4, F0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, F0/10, F0/11, F0/12, F0,13, F0/14
F0/15, F0,16
3 kinhdoanh active F0/17, F0/18, F0/19, F0/20, F0/21, F0,22
F0/23, F0,24
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup


VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
30 enet 100030 1500 - - - - - 0 0

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - srb 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

// Sau khi sử dụng câu lệnh Show vlan để kiểm tra thông tin vlan cũng như các interface thuộc VLAN, trạng thái của VLAN, chúng ta thấy trên Switch 1, Switch 2 thông tin VLAN cũng như các Interface thuộc VLAN đã đúng theo yêu cầu đầu bài. Như vậy việc cấu hình đã hoàn tất, lúc đó chúng ta mới thực hiện lưu cấu hình vào NVRAM


4. lưu cấu hình vào NVRam 
Switch1#copy running-config startup-config
Switch2#copy running-config startup-config

0 nhận xét:

Đăng nhận xét