Thứ Bảy, 15 tháng 6, 2013

Hướng dẫn cấu hình OSPF full trên packet tracer

I. Giới thiệu
- OSPF Là giao thức định tuyến nhóm link-state, thường được triển khai trong các hệ thống mạng phức tạp. Giao thức OSPF tự xây dựng những cơ chế riêng cho mình ,tự bảo đảm những quan hệ của chính mình với các router khác. Nó có thể dò tìm nhanh chóng sự thay đổ của topology (cũng như lỗi của các interface ) và tính toán lại những route mới sau chu kỳ hội tụ. Chu kỳ hội tụ của OSPF rất ngắn và cũng tốn rất ít lưu lượng đường truyền.


- OSPF khá thuận tiện và phổ biến vì các tính năng của mình và vì nó là chuẩn mở trong thực tế OSPF được sử dụng khá nhiều trong các mô hình mạng vừa và lớn. Nhược điểm của giao thức này là Bộ vi lí của Router phải đủ mạnh cũng như các yêu cầu về phần cứng khác khá cao.

II. Mô hình


III. Yêu cầu
1. Cấu hình khởi tạo cho các thiết bị mạng.
- đặt tên
- cấu hình Banner mote
- cấu hình password cho console, telnet, Privileged.
Password console: itn
Password telnet: itn
Password Privileged: itn
2. Cấu hình các interface của router.
- cấu hình địa chỉ IP
- cấu hình description
- cấu hình enable các interface
3. Cấu hình định tuyến
- cấu hình định tuyến dùng OSPF
- khởi tạo giao thức định tuyến OSPF
- xác định các mạng connect và cac area
- quảng bá các mạng connect
- cấu hình Authentication trên hai cổng s1/0 của Router1 va Router2 với password là itn
4. Kiểm tra
- dùng câu lệnh Show running-config để kiểm tra cấu hình đã đúng hay chưa.
- dùng câu lệnh Show ip route để kiểm tra bảng định tuyến.
- dùng câu lệnh Ping để kiểm tra kết nối giữa các mạng.
- sau khi cấu hình Authentication sử dụng câu lệnh debug để kiểm tra trạng thái của gói tin thay đổi thế nào khi cấu hình Authentication trên từng Router một


IV. cấu hình chi tiết
1. cấu hình cơ bản
1.1 cấu hình khởi tạo các thiết bị mạng
1.1.1 Router 1
- Cấu hình đặt tên
Router>enable
Router#configure terminal
Router(config)#hostname Router1
Router1(config)#

- cấu hình Banner mote

Router1(config)#banner motd " Router_1 "

- cấu hình console
Router1(config)#line console 0
Router1(config-line)#password itn
Router1(config-line)#login
Router1(config-line)#exit


- cấu hình telnet
Router1(config)#line vty 0 4
Router1(config-line)#password itn
Router1(config-line)#login
Router1(config-line)#exit


- cấu hình password privileged

Router1(config)#enable secret itn

- Cấu hình các interface của router
Router1(config)#interface serial 1/0
Router1(config-if)#ip address 192.168.2.1 255.255.255.0
Router1(config-if)#description ket noi toi router 2
Router1(config-if)#clock rate 64000
Router1(config-if)#no shutdown
Router1(config-if)#exit


Router1(config)#interface fastEthernet 2/0
Router1(config-if)#ip address 192.168.1.1 255.255.255.0
Router1(config-if)#description ket noi toi lan
Router1(config-if)#no sh
Router1(config-if)#exit


1.1.2 Router 2
- Cấu hình đặt tên

Router>enable
Router#configure terminal
Router(config)#hostname Router2
Router2(config)#


- cấu hình Banner mote
Router2(config)#banner motd " Router_2 "

- cấu hình console
Router2(config)#line console 0
Router2(config-line)#password itn
Router2(config-line)#login
Router2(config-line)#exit


- cấu hình telnet
Rter2(config)#line vty 0 4
Router2(config-line)#password itn
Router2(config-line)#login
Router2(config-line)#exit


- cấu hình password privileged
Router2(config)#enable secret itn

- Cấu hình các interface của router
Router2(config)#interface serial 1/0
Router2(config-if)#ip address 192.168.2.2 255.255.255.0
Router2(config-if)#description ket noi toi router 1
Router2(config-if)#clock rate 64000
Router2(config-if)#no shutdown
Router2(config-if)#exit


Router2(config)#interface fastEthernet 2/0
Router2(config-if)#ip address 192.168.3.1 255.255.255.0
Router2(config-if)#description ket noi toi lan
Router2(config-if)#no sh
Router2(config-if)#exit

1.2 Kiểm tra các tuyến trong bảng định tuyến của các Router trước khi cấu hình định tuyến
Router1
- Kiểm tra trạng thái và địa chỉ IP của các interface sử dụng câu lệnh


Router1#show ip interface brief
Interface IP-Address OK? Method Status Protocol
Serial1/0 192.168.2.1 YES manual up up
Serial1/1 unassigned YES unset administratively down down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
FastEthernet2/0 192.168.1.1 YES manual up up 


- kiểm tra xem các cấu hình bên trên đã đúng chưa sử dụng câu lệnh

Router1#show running-config
Building configuration...


Current configuration : 898 bytes
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname Router1
boot-start-marker
boot-end-marker
!
enable secret itn
interface Serial1/0
description Ket noi toi Router2
ip address 192.168.2.1 255.255.255.0
serial restart-delay 0
clock rate 64000
interface FastEthernet2/0
description Ket noi toi Lan
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
no keepalive
line con 0
line aux 0
line vty 0 4
password itn
login
!
end.

- kiểm tra bảng định tuyến sử dụng 

Router1# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route


Gateway of last resort is not set

C 192.168.1.0/24 is directly connected, FastEthernet2/0
C 192.168.2.0/24 is directly connected,Serial1/0

//hiện thời trong bảng định tuyến chỉ có hai mạng connect được kí hiệu là chữ “C” trong bảng định tuyến mạng 192.168.3.0/24 chưa có trong bảng định tuyến vì chưa có giao thức định tuyến nào được Enable trong mạng.

Kiểm tra tương tự đối với Router2

2. Cấu hình định tuyến sử dụng OSPF
2.1 Router1
khởi tạo giao thức đinh tuyến ospf

Router1(config)#ospf 100

quảng bá các mạng connect
Router1(config-router)#network 192.168.1.0 0.0.0.255 area 1
Router1(config-router)#network 192.168.2.0 0.0.0 255 area 0
Router1(config-router)#exit

2.2 Router2
khởi tạo giao thức đinh tuyến ospf
Router2(config)#router ospf 100

quảng bá các mạng connect
Router2(config-router)#network 192.168.3.0 0.0.0.255 area 2
Router2(config-router)#network 192.168.2.0 0.0.0.255 area 0
Router2(config-router)#end


//khi quảng bá các mạng connect chú ý các area khác 0 cần kết nối trực tiếp đến area 0 còn goi là area Backbone các router ở giữa hai area là router boder nó có thông tin định tuyến của cả hai area

3. Kiểm tra định tuyến

3.1 kiểm tra neighbor
- Để kiểm tra xem hai Router đã thiết lập neighbor với nhau chưa ta sử dụng câu lệnh:
3.1.1 Router1
Router1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
192.168.3.1 0 FULL/ - 00:00:38 192.168.2.2 Serial1/0 


3.1.2 Router2
Router2#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
192.168.2.1 0 FULL/ - 00:00:31 192.168.2.1 Serial1/0


- Ở trên cho thấy hai Router đã thiết lập Neighbor với nhau tiếp theo ta kiểm tra đến quá trình định tuyến.

3.2 Kiểm tra bảng định tuyến
3.2.1 Router1
- Sau khi quá trình đinh tuyến hoàn tất các đường đi đến các mạng không connect sẽ được lưu trong bảng định tuyến với kí tự là chữ “O”:

Router1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route


Gateway of last resort is not set

C 192.168.1.0/24 is directly connected, FastEthernet2/0
C 192.168.2.0/24 is directly connected, Serial1/0
O IA 192.168.3.0/24 [110/65] via 192.168.2.2, 00:00:15, Serial1/0
//Sau khi được cấu hình định tuyến đường đi tới mạng 192.168.3.0/24 đã có trong bảng định tuyến với kí tự trong bảng định tuyến là chữ “O”.

Tương tự đối với Router2

3.3 Kiểm tra thông mạng
- Đứng từ các lan ping sang các mạng không connect va kiểm tra kết quả
3.3.1 Đứng trên Router1

Router1#ping 192.168.3.0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.0, timeout is 2 seconds:
.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 288/746/1848 ms 

3.3.2 Đứng trên Router2
Router2#ping 192.168.1.0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.0, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 332/588/1248 ms


- Dùng lệnh clear ip route * để xoá toàn bộ route từ bảng định tuyến.
Router1# clear ip route *


- Dùng lệnh clear ip ospf process hoặc reload để kích hoạt lại quá trình định tuyến ospf.
Router1#clear ip ospf process

4 cấu hình Authentication
- OSPF hỗ trợ Authentication và Authentication được đặt trên các interface khi cấu hình chứng thực thì để có thể bắt tay và xây dựng bảng đinh tuyến các interface phải được cấu hình Authentication đồng bộ password và encapsulation với nhau, việc này đóng vai trò quan trọng trong về vấn đề bảo mật cho mạng.
Trên Router1
- Cấu hình:

Router1(config-if)#interface Serial 1/0
Router1(config-if)#ip ospf authentication
Router1(config-if)#ip ospf authentication-key itn

- Kiểm tra
Ngay sau khi cấu hình Authentication trên Router1 hai router sẽ không còn có thể bắt tay thiết lập neighbor được nữa .

Router1#show ip ospf neighbor
Router1#*Mar 1 2311.154: %OSPF-5-ADJCHG: Process 100, Nbr 192.168.3.1 on Serial1/0 from FULL to DOWN, Neighbor Down: Dead timer expired


- Tiến hành câu lệnh Debug ip ospf events để kiểm tra nguyên nhân .
Router1#debug ip ospf events
OSPF events debugging is on
Router1#
*Mar 1 2350.434: OSPF: Rcv pkt from 192.168.2.2, Serial1/0 : Mismatch Authentication type. Input packet specified type 0, we use type 1
*Mar 1 2351.682: OSPF: Send hello to 224.0.0.5 area 1 on FastEthernet2/0 from 192.168.1.1
*Mar 1 2352.750: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0 from 192.168.2.1
*Mar 1 2300.518: OSPF: Rcv pkt from 192.168.2.2, Serial1/0 : Mismatch Authentication type. Input packet specified type 0, we use type 1
*Mar 1 2301.686: OSPF: Send hello to 224.0.0.5 area 1 on FastEthernet2/0 from 192.168.1.1
*Mar 1 2302.754: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0 from 192.168.2.1ungdeb all

// Câu lệnh Debug cho thấy hai Router không thể thiết lập neighbor là vì quá trình Authentication không được match với nhau. Để hai Router có thể thiết lập lại neighbor và hoàn thành quá trình định tuyến ta cần phải cấu hình Authentication trên Router2

4.3 Trên Router2
// khi cấu hình authentication trong ospf cần chú ý để quá trình bắt tay giữa hai router hoàn thành thì password và encapsulation cần giống nhau.

- Cấu hình
Router1(config-if)#interface Serial 1/0
Router2(config-if)#ip ospf authentication
Router2(config-if)#ip ospf authentication-key itn


- Kiểm tra
Sau khi cấu hình Authentication trên Router2 tiến hành kiểm tra các gói tin bằng câu lệnh Debug ip ospf events


Router1#debug ip ospf events
OSPF events debugging is on
Router1#
*Mar 1 2311.806: OSPF: Send hello to 224.0.0.5 area 1 on FastEthernet2/0 from 192.168.1.1
*Mar 1 2312.782: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0 from 192.168.2.1
*Mar 1 2313.482: OSPF: Rcv hello from 192.168.3.1 area 0 from Serial1/0 192.168.2.2
*Mar 1 2313.486: OSPF: End of hello processing


// Ở trên cho thấy quá trình gửi gói tin thiết lập neighbor đã hoàn thành tiếp tuc kiểm tra neighbor của hai Router với câu lệnh Show ip ospf neighbor
Router1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
192.168.3.1 0 FULL/ - 00:00:30 192.168.2.2 Serial1/0


Router2#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
192.168.2.1 0 FULL/ - 00:00:32 192.168.2.1 Serial1/0

- như vậy sau khi tiến hành cấu hình đồng nhất Authentication trên cả hai Router hai Router đã thiết lập neighbor trở lại với nhau. Bây giở thử kiểm tra bảng định tuyến với câu lệnh
Show ip Route


Router1
Router1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route


Gateway of last resort is not set

C 192.168.1.0/24 is directly connected, FastEthernet2/0
C 192.168.2.0/24 is directly connected, Serial1/0
O IA 192.168.3.0/24 [110/65] via 192.168.2.2, 00:00:15, Serial1/0

Trên Router2
Router2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route


Gateway of last resort is not set

O IA 192.168.1.0/24 [110/65] via 192.168.2.1, 00:01:04, Serial1/0
C 192.168.2.0/24 is directly connected, Serial1/0
C 192.168.3.0/24 is directly connected, FastEthernet2/0
// mạng đã định tuyến bình thường chứng tỏ Authentication hoàn tất ta tiến hành lưu cấu hình vào NVRam.

V. lưu cấu hình vào NVRam
Sau khi mọi cấu hình hoàn tất tiến hành lưu cấu hình hiện thời vào NVRam 

Router1#copy running-config startup-config
Router1#copy running-config startup-config

0 nhận xét:

Đăng nhận xét