Thứ Ba, 11 tháng 6, 2013

Cấu hình chứng thực authentication trong RIPv2

Topology



Yêu cầu:

Cấu hình RIPv2 và cấu hình chứng thực giữa 2 router dạng Plain Text.

Hướng dẫn cấu hình

1. Cấu hình cơ bản

R1(config)#interface Fa0/0
R1(config-if)#ip address 192.168.12.1 255.255.255.252
R1(config-if)#no shutdown

R1(config)#interface lo0
R1(config-if)#ip address 172.16.10.1 255.255.255.0
R1(config-if)#no shutdown

R2(config)#interface Fa0/0
R2(config-if)#ip address 192.168.12.2 255.255.255.252
R2(config-if)#no shutdown

R2(config)#interface lo0
R2(config-if)#ip address 172.16.20.1 255.255.255.0
R2(config-if)#no shutdown

2. Cấu hình định tuyến RIPv2

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 172.16.0.0
R1(config-router)#network 192.168.12.0
R1(config-router)#no auto-summary

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 172.16.0.0
R2(config-router)#network 192.168.12.0
R2(config-router)#no auto-summary

3. Cấu hình chứng thực plaint text giữa R1 & R2

R1(config)#key chain ccna
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string newstar

R1(config)#interface Fa0/0
R1(config-if)#ip rip authentication key-chain ccna

R2(config)#key chain ccna
R2(config-keychain)#key 1
R2(config-keychain-key)#key-string newstar

R2(config)#interface Fa0/0
R2(config-if)#ip rip authentication key-chain ccna

Topology



Yêu cầu:

Cấu hình RIPv2 và cấu hình chứng thực giữa 2 router dạng MD5.

Hướng dẫn cấu hình

1. Cấu hình cơ bản

Tương tự

2. Cấu hình định tuyến RIPv2

Tương tự

3. Cấu hình chứng thực MD5 giữa R1 & R2

R1(config)#key chain ccna
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string newstar

R1(config)#interface Fa0/0
R1(config-if)#ip rip authentication key-chain ccna
R1(config-if)#ip rip authentication mode md5

R2(config)#key chain ccna
R2(config-keychain)#key 1
R2(config-keychain-key)#key-string newstar

R2(config)#interface Fa0/0
R2(config-if)#ip rip authentication key-chain ccna
R2(config-if)#ip rip authentication mode md5

0 nhận xét:

Đăng nhận xét