This is my blog: vuvanson.tk

Go to Blogger Vi-et Spaces.

This is my blog: sonblog.tk

Go to Blogger Vi-et Spaces.

This is my blog: vi-et.tk

Go to Blogger Vi-et Spaces.

This is my facebook: https://www.facebook.com/vusonbk

Go to Facebook Blogger Vi-et Spaces.

This is my facebook page: https://www.facebook.com/ViEtSpaces

Go to Facebook Page Blogger Vi-et Spaces.

Thứ Ba, 16 tháng 4, 2019

Sử dụng Symbolic Link để upload dữ liệu lên Dropbox từ bất kỳ thư mục nào

Sử dụng Symbolic Link để upload dữ liệu lên Dropbox từ bất cứ thư mục nào
Nếu bạn sử dụng Dropbox thì sẽ thấy có một bất tiện : nếu muốn đưa dữ liệu lên tài khoản Dropbox (xem bài viết về Dropbox tại đây), bạn phải chép nó vô thư mục Dropbox trên máy tính. Và tôi gặp vấn đề từ đây : ổ C của tôi hiện tại chỉ còn trống khoảng 2.5Gb và nếu tôi muốn upload 2Gb hình lên Dropbox, tôi buộc phải chép nó vô thư mục Dropbox trên ổ C và khi đó, ổ C chỉ còn trống khoảng 500Mb ! Vậy những lần sau thì sao ?
Và tôi liền nghĩ đến Symbolic Links, thứ mà tôi có dịp vọc và tìm hiểu vài năm trước, tôi liền áp dụng thử và nó đã thành công. Bạn hãy tưởng tượng một kịch bản như thế này : Thư mục Dropbox mặc định sẽ lưu trong thư mục MyDocument trong ổ C. Giờ tôi có thể upload lên Dropbox một thư mục hình ảnh từ ổ D mà không cần phải chép thư mục đó vào thư mục Dropbox (ở ổ C) như thông thường ! Bất cả chỉ được thực hiện bằng một dòng lệnh…

Trước tiên xin giải thích sơ qua về Symbolic links, chi tiết bạn có thể tự tìm hiểu trên mạng. Symbolic Links là một loại tập tin mà nó tham chiếu đến một tập tin hoặc thư mục khác và chỉ sử dụng được nếu ổ đĩa được format ở định dạng NTFS (đối với Windows). Ví dụ : tôi có một thư mục “anhhangxom” trên ổ C và tôi sử dụng symbolic links để tạo một thư mục “anhhangxomonline” trên ổ D, lúc này thư mục “anhhangxomonline” sẽ có toàn bộ dữ liệu của thư mục “anhhangxom”. Nhìn thì bạn sẽ thấy nó giống như là một Shortcut nhưng thực sự không phải. Với các dạng shortcut thông thường, nó luôn mở ra thư mục hoặc tập tin gốc nhưng với dạng Symbolic Links thì không.
Mặc dù thư mục “anhhangxomonline” tham chiếu đến thư mục “anhhangxom” trên ổ C nhưng khi bạn mở nó ra, bạn sẽ thấy thanh địa chỉ sẽ hiển thị đường dẫn là chính nó, tức là “D:anhhangxomonline” (thay vì “C:anhhangxom” nếu như đó là một shortcut). Mọi thay đổi trong 2 thư mục này đều được cập nhật qua lại và có một điều mà bạn lưu ý là : thư mục anhhangxomonline hoàn toàn không chứa dữ liệu và chiếm dụng dung lượng ổ đĩa D bởi vì nó chỉ là một thư mục tham chiếu đến thư mục gốc ở địa chỉ : C:anhhangxom.
Giải thích cái này đuối hàng luôn, hồi mới tìm hiểu nó vài năm trước, tôi cũng chả hiểu rốt cuộc nó là cái gì và rất là rối. Giờ thì ổn rồi, hehe.
Trong trường hợp của Dropbox, tôi buộc phải dùng Symbolic Links bởi vì không thể sử dụng một shortcut ở đây được. Cách làm cụ thể như sau : Giờ tôi sẽ tạo một Symbolic Links cho thư mục “anhhangxomonline” trên ổ D (chứa dữ liệu cần upload lên Dropbox), tôi sẽ đặt tên cho nó là “anhhangxom” (tên gì cũng được) và lưu nó trong thư mục Dropbox :
Vào Start > Run > gõ dòng lệnh “cmd” để mở Command Prompt. Cửa sổ hiện ra như sau :
Sử dụng Symbolic Link để upload dữ liệu lên Dropbox từ bất cứ thư mục nào
Gõ dòng lệnh mklink /d “C:UserssoftvinhDocumentsMy Dropboxanhhangxom” “D:anhhangxomonline”
Trong thư mục Dropbox sẽ có một thư mục con có tên là “anhhangxom” và quá trình đồng bộ dữ liệu lên Dropbox sẽ bắt đầu.
Sử dụng Symbolic Link để upload dữ liệu lên Dropbox từ bất cứ thư mục nào
Thư mục gốc (chứa dữ liệu thật cần upload lên dropbox) được lưu trên ổ D :
Sử dụng Symbolic Link để upload dữ liệu lên Dropbox từ bất cứ thư mục nào
Lưu ý :
– Nếu bạn xóa thư mục tham chiếu “anhhangxom”, thư mục gốc sẽ không bị ảnh hưởng gì hết và vẫn tồn tại. Nhưng nếu bạn thay đổi nội dung thư mục “anhhangxom” (xóa, tạo mới, cập nhật) thì nội dung đó sẽ được cập nhật trên thư mục gốc !
– Nếu bạn xóa thư mục gốc “anhhangxomonline” thì đơn giản là thư mục tham chiếu “anhhangxom” sẽ không thể truy xuất được nữa. Bạn sẽ nhận được thông báo :
– Trong trường hợp sử dụng Dropbox. Sau khi tạo thư mục tham chiếu “anhhangxom”, nếu bạn xóa thư mục gốc (thư mục “anhhangxomonline” trên ổ D) thì không sao hết, dữ liệu trên Server của Dropbox vẫn còn đó bởi vì thư mục tham chiếu “anhhangxom” vẫn còn tồn tại. Còn nếu bạn xóa thư mục tham chiếu “anhhangxom”, dữ liệu trên Server cũng bị xóa do tính năng đồng bộ của Dropbox.
Thôi, phải ngừng lại ở đây thôi, không dám đọc lại bài viết này bởi vì tôi sợ tác giả của nó cũng sẽ bị “tẩu hỏa nhập ma”, haha.

Thứ Hai, 15 tháng 4, 2019

Liên kết tượng trưng là gì? Làm cách nào để tạo Symlinks trong Windows 10?

Liên kết tượng trưng là gì? Làm cách nào để tạo Symlinks trong Windows 10?
Geoffrey Carr
Liên kết tượng trưng - còn được gọi là liên kết tượng trưng hoặc liên kết mềm - có thể là một trong những khái niệm ẩn nhất cho người dùng máy tính. Tuy nhiên, điều đó không lấy đi tầm quan trọng của nó và những lợi ích mà nó mang lại. Làm cách nào để truy cập các thư mục và tệp từ các thư mục khác nhau mà không cần duy trì các bản sao trùng lặp? Vâng, đó là sức mạnh của Liên kết tượng trưng.

Liên kết tượng trưng hoặc liên kết tượng trưng là gì

Liên kết biểu tượng là các tệp lối tắt đề cập đến tệp hoặc thư mục vật lý được đặt ở nơi khác. Liên kết hoạt động như các tệp hoặc thư mục ảo, có thể được sử dụng để liên kết với các tệp hoặc thư mục riêng lẻ, làm cho chúng xuất hiện như thể chúng được lưu trữ trong thư mục với các Liên kết, mặc dù các Liên kết chỉ trỏ đến vị trí thực của chúng.
Đừng nhầm lẫn giữa các liên kết với Symlink
Điều quan trọng là phải hiểu rằng các liên kết tượng trưng không chỉ là các phím tắt mà là một người dùng Windows mà bạn đã biết. Một tập tin phím tắt chỉ đơn giản là trỏ đến tập tin mong muốn trong khi Symlink sẽ làm cho nó trông giống như các tập tin được liên kết là thực sự ở đó. Khi bạn nhấp vào liên kết, bạn sẽ được chuyển đến vị trí tệp thực tế.

Cấu trúc của một liên kết tượng trưng

Một Symlink là một chuỗi văn bản được tự động diễn giải và tiếp theo là hệ điều hành dưới dạng đường dẫn đến một tệp hoặc thư mục khác. Tệp hoặc thư mục khác này được gọi là "Mục tiêu“.
Symlink tồn tại độc lập với mục tiêu của nó. Nếu một liên kết bị xóa, mục tiêu của nó vẫn không bị ảnh hưởng. Nếu một liên kết tượng trưng trỏ đến đích và một thời gian sau đó mục tiêu đó được di chuyển, đổi tên hoặc xóa, liên kết tượng trưng sẽ không tự động được cập nhật hoặc xóa, nhưng vẫn tiếp tục tồn tại và vẫn trỏ đến mục tiêu cũ. Tuy nhiên, trong các Liên kết tượng trưng như vậy trỏ tới mục tiêu di chuyển hoặc không tồn tại đôi khi được gọi là bị hỏng, mồ côi, chết hoặc lơ lửng.

Lợi ích của các liên kết

  1. Các liên kết tượng trưng tiêu thụ rất ít không gian và rất nhanh để tạo ra. Bạn tiết kiệm rất nhiều không gian đĩa cứng với các liên kết
  2. Trái với các liên kết cứng, các liên kết tượng trưng có thể liên kết đến các tệp trên các hệ thống tệp. Hãy nhớ rằng, nếu bạn xóa tệp gốc, liên kết cứng vẫn giữ cho tệp đó hoạt động, một Liên kết tượng trưng không
  3. Các liên kết tượng trưng duy trì cấu trúc thư mục trong đó các Liên kết được chứa. Ví dụ: giả sử có một txt tệp được chứa trong “Tiện ích” thư mục được đặt tại /D/Myfolder/Utility/windowsclub.txt . Bây giờ nếu một Liên kết tượng trưng cho Tiện ích thư mục đã được tạo trong thư mục Dropbox và bạn đã tìm kiếm windowsclub.txt trong thư mục Dropbox, đường dẫn tệp sẽ đọc /D/Myfolder/Utility/windowsclub.txt thay vì chuyển về đường dẫn tệp gốc / thực.
  4. Sử dụng Symlinks, bạn có thể lưu trữ các tệp phương tiện của mình Âm nhạc / Video trên một ổ cứng khác, nhưng làm cho chúng hiển thị trong thư mục Music / Videos chuẩn của bạn, vì vậy chúng sẽ được phát hiện bởi các chương trình truyền thông của bạn
  5. Nhà phát triển thường thay thế các bản sao của các tệp / thư mục được chia sẻ bằng các liên kết tượng trưng tham chiếu đến các tệp / thư mục vật lý. Thay thế các bản sao dự phòng của các tệp có thể tiết kiệm rất nhiều không gian đĩa vật lý và giảm đáng kể thời gian thực hiện để sao chép / sao lưu / triển khai / sao chép dự án.
Tầm quan trọng của các liên kết trong thế giới phát triển ngày nay
Với tư cách là Yosef Durr, Giám đốc chương trình cấp cao, Microsoft đề cập đến Blog của Windows,
Many popular development tools like git and package managers like npm recognize and persist symlinks when creating repos or packages, respectively. When those repos or packages are then restored elsewhere, the symlinks are also restored, ensuring disk space (and the user’s time) isn’t wasted. Git, for example, along with sites like GitHub, has become the main go-to-source code management tool used by most developers today.
Việc sử dụng các nhà quản lý gói trong phát triển hiện đại cũng đã bùng nổ trong những năm gần đây. Ví dụ: trình quản lý gói nút (npm) đã phân phối ~ 400 triệu lượt cài đặt trong tuần ngày 1 tháng 7 năm 2015 nhưng đã phân phát hơn 1,2 tỷ lượt cài đặt chỉ một năm sau đó - tăng gấp 3 lần chỉ trong một năm! Vào cuối tháng 6 năm 2016, npm đã phục vụ hơn 1,7 tỷ gói nút chỉ trong bảy ngày!

Các liên kết trong Windows 10

Mặc dù các liên kết Symlink có những ưu điểm khác biệt, nhưng nó chủ yếu được sử dụng bởi các hệ điều hành tương thích với UNIX như Linux, FreeBSD, OSX, vv, nơi các liên kết tượng trưng có thể được tạo mà không bị giới hạn. Đối với người dùng Windows, mặc dù các liên kết đã được tạo sẵn bắt đầu từ Windows Vista, nhưng rất khó để tạo ra.
Do yêu cầu bảo mật của Windows Vista, người dùng cần quyền quản trị cục bộ và quan trọng là phải chạy mlink trong một giao diện điều khiển dòng lệnh được nâng lên với tư cách quản trị viên để tạo / sửa đổi các Liên kết. Hạn chế thứ hai này dẫn đến các liên kết không thường xuyên được sử dụng bởi hầu hết các nhà phát triển Windows và gây ra nhiều công cụ phát triển đa nền tảng hiện đại để làm việc kém hiệu quả và đáng tin cậy hơn trên Windows.
Tuy nhiên, bây giờ với Cập nhật Windows 10 người sáng tạo, khi người dùng có quyền quản trị bật Chế độ nhà phát triển, bất kỳ ai trên PC đều có thể chạy mklink lệnh mà không cần nâng cấp bảng điều khiển dòng lệnh.

Làm thế nào để bạn tạo ra các liên kết

Các liên kết có thể được tạo bằng cách sử dụng lệnh mklink hoặc là API CreateSymbolicLink.
Sử dụng lệnh mklink
Trong khi sử dụng lệnh mklink, sử dụng cú pháp dưới đây:
“mklink /prefix link_path file/folder_path”
Lưu ý: mklink có thể tạo một số loại liên kết. Dưới đây là các loại-
  • / D Tạo liên kết tượng trưng cho thư mục. Mặc định là một liên kết tượng trưng cho tệp.
  • / H Tạo một liên kết cứng thay vì liên kết tượng trưng.
  • / J Tạo một Junction Directory.
Ví dụ, tôi đã tạo một đường giao tiếp thư mục của thư mục Music của tôi trên màn hình nền của mình. Tham khảo ảnh chụp màn hình dưới đây-
Vì vậy, khi tôi nhấp vào Liên kết tượng trưng, ​​có vẻ như các tệp nhạc của tôi được lưu trữ trongC: Users Desktop Music mặc dù ban đầu nó xuất hiện trong C: Users Âm nhạc.
Hãy nhớ rằng, nếu con đường của bạn có bất kỳ khoảng trống nào trong đó, thì bạn cần đặt dấu ngoặc kép xung quanh nó.
Sử dụng CreateSymbolicLink
Để kích hoạt hành vi mới khi sử dụng API CreateSymbolicLink, có thêm dwFlags tùy chọn bạn sẽ cần đặt giá trị là:
SYMBOLIC_LINK_FLAG_ALLOW_UNPRIVILEGED_CREATE
0x2
Vì vậy, bằng cách chọn giá trị trên, bạn đã chỉ định cờ để cho phép tạo liên kết tượng trưng khi quá trình này không được nâng lên.
Để đọc thêm về cách tạo liên kết bằng cách sử dụng CreateSymbolicLink API, truy cập windows.com.
Phần kết luận
Có thể nói rằng các liên kết của Symlink hữu ích hơn các shortcut đơn thuần tuy nhiên chúng hơi khó tạo. Một người dùng PC trung bình vẫn có thể thấy nó hơi đáng sợ để tạo ra. Hơn nữa, ngay cả ngày hôm nay, nhiều người dùng đang cố gắng hiểu khái niệm về các phím tắt tốt và do đó có thể đấu tranh để phân biệt các Liên kết và hiểu được việc sử dụng nó.
Có nói rằng, nó gần như là một đảm bảo rằng bạn sẽ thấy dễ dàng thay đổi bất kỳ cài đặt nào bạn có thể sao cho chương trình trỏ đến đúng thư mục và bạn không thực sự tạo một Liên kết, nhưng biết cách thiết lập và sử dụng một Symlink tốt có thể thực sự tiện dụng.

Thứ Sáu, 5 tháng 4, 2019

Tưởng rằng ...



Tưởng rằng gió thoáng qua thôi
Tình yêu đôi lúc như mưa ngoài thềm
Mặc cho biển có rộng, sâu
Mênh mông sóng nước, bể dâu cuộc đời

Tưởng rằng có cách muôn nơi
Phận duyên ta gặp được người mến thân
Chẳng ai sống đến hai lần
Chỉ tình yêu đẹp muôn ngàn lần thôi...

Thứ Hai, 11 tháng 3, 2019

Giới hạn Bandwidth trên Switch Cisco

Giới hạn Bandwidth trên Switch Cisco: Bài này sẽ hướng dẫn các bạn cách làm sao để người quản trị mạng LAN có thể kiểm soát được băng thông kết nối từ bên trong ra bên ngoài internet trong hệ thống mạng LAN.

B1. Kích hoạt tính năng QoS

mls qos

B2. Tạo Extended Access cho phép mọi truy cập
ip access-list extended ACL_8M
permit ip any any


B4. Tạo class map để phân loại các traffic
class-map match-all CLASS_8M
match access-group name ACL_8M

B5. Tạo Policy
policy-map POLICY_8M
class CLASS_8M
police 8000000 100000 exceed-action drop interface

Trong đó: 8000000 là tốc độ tính bằng bit/s, 8000000 bit/s = 8Mbps, đây là tốc độ mà bạn muốn gán cho cổng mạng.
100000 là burst size tính bằng byte, vấy đề là chọn burst size sao cho không ảnh hưởng đến hiệu suất của mạng. Thông thường độ trể cho phép của một mạng từ 1 đến 600 ms. Trong ví dụ này mình chọn đỗ trể là 50ms=0.05s, mình sẽ tính ra tốc độ burst size theo công thức như sau: burst size = 2 * (8000000bps/8) * 0.05s = 100000byte

B6. Gán Policy cho cổng mạng muốn hạn chế tốc độ
GigabitEthernet0/2
service-policy input POLICY_8M
Trong ví dụ này input là chiều đi vào cổng mạng (Client upload dữ liệu lên mạng)

Trường hợp ngược lại ouput là chiều đi ra khỏi cổng mạng (Client download dữ liệu về máy)
GigabitEthernet0/2
service-policy output POLICY_8M

Chủ Nhật, 10 tháng 3, 2019

NỖI NIỀM THÁNG HAI



Đã qua rét lộc rét đài
Tháng giêng dừng lại, tháng Hai qua dần
Làng quê tràn ngập sắc xân
Nửa phần trần thế, nửa phần Đào nguyên

Sông xa thấp thoáng bóng thuyền
Người về lễ hội, người lên cửa chùa
Dẫu rằng trời vẫn còn mưa
Thế nhưng ướt át cũng chừa bờ vai

Giêng Hai ngày rộng tháng dài
Nào ai hò hẹn, nào ai đợi chờ
Tôi nay cũng góp vần thơ
Kẻo rồi mang tiếng hững hờ với Xuân...

Chủ Nhật, 3 tháng 3, 2019

Lòng người



Sự đời khôn dại, dại khôn
Cứ vô tư chẳng dỗi hờn so đo
Cuộc đời sao cứ âu lo
Cứ thương cứ quý khó đo lòng người...

Thứ Năm, 21 tháng 2, 2019

Nụ cười



Gặp nhau vui vẻ hỏi chào
Nụ cười rạng rỡ ta trao thân tình
Cùng nhau chào đón mỗi ngày
Luyện rèn tri thức cho thêm yêu đời

Bạn bè thân ái yêu thương
Tâm tình chia sẻ sớm chiều vui tươi
Không ai mua bán nụ cười
Chỉ dành trao tặng để đời thêm vui...

Thứ Sáu, 15 tháng 2, 2019

MỪNG THỌ



Mừng thọ các cụ cao niên
Thành tâm kính chúc khỏe quên tuổi già
Cháu con quý trọng ông cha
Gia đình hạnh phúc thuận hòa vui tươi

Hòa đồng cùng với mọi người
Tinh thần sảng khoái mấy mươi chưa già
Xuân về nở rộ muôn hoa
Chúc mừng các cụ tuổi già an khang.

Thứ Tư, 6 tháng 2, 2019

Tết này ta trở về quê



Tết này ta trở về quê
Xóm làng yên ả với nghề Nông gia
Ngày xưa đất tốt trồng cà
Bây giờ đất tốt trồng hoa bốn mùa

Vào Xuân-Trời nhẩn nha mưa
Đôi làn gió ấm khẽ lùa đồng xanh
Đường thôn hoa nở trắng cành
Sao vàng cờ đỏ vờn quanh mái đình

Người xinh bên khóm trúc xinh
Đâu đây tiếng hát ấm tình lả lơi
Để ta thương nhớ một đời
Để ta hết đứng lại ngồi đêm nay...

Thứ Sáu, 1 tháng 2, 2019

Lỗi client for microsoft networks- Hai PC không thấy nhau

Từ vấn đề cấp bách như không thể chia sẻ các file giữa các máy tính trong mạng hay một vấn đề đơn giản nào đó, loạt bài gồm hai phần này chúng tôi cũng sẽ đề cập đến tất cả các khía cạnh trong việc khắc phục sự cố trong mạng chia sẻ. Trong phần một này, chúng tôi sẽ giới thiệu cho các bạn cách refresh thiết bị mạng của mình và thẩm định các thiết lập chia sẻ, tường lửa và Router đã được cấu hình.
Các vấn đề máy tính nhiều khi có thể gây sự bực mình – đặc biệt các vấn đề mạng và chia sẻ dữ liệu. Nhiều khía cạnh trong việc kết nối mạng có thể là nguyên nhân gây ra vấn đề. Cho ví dụ như các thiết lập mà bạn hoặc ai đó có thể do vô tình nhưng đã làm cho những người dùng khác không thể thấy các file trên mạng.
Một số các thiết lập chỉ đơn giản như không được cấu hình đúng. Bên cạnh đó hệ điều hành Windows và công nghệ mạng nằm bên dưới đôi khi cũng có thể phát sinh các vấn đề.
Dù đó là vấn đề nào đi chăng nữa, trong hướng dẫn gồm hai phần này, chúng tôi sẽ tổng kết lại cho các bạn các nhiệm vụ khắc phục sự cố và kỹ thuật làm cho các máy tính có thể chia sẻ dữ liệu với nhau.
Chúng ta sẽ bắt đầu bằng việc refresh mạng và khởi động lại các máy tính lẫn các thiết bị mạng. Tiếp đó bạn cần bảo đảm rằng các thiết lập chia sẻ, tường lửa và Router cũng được cấu hình đúng cách.

Thứ Sáu, 18 tháng 1, 2019

Giới hạn Bandwidth trên Switch Cisco

Giới hạn Bandwidth trên Switch Cisco: Bài này sẽ hướng dẫn các bạn cách làm sao để người quản trị mạng LAN có thể kiểm soát được băng thông kết nối từ bên trong ra bên ngoài internet trong hệ thống mạng LAN.

B1. Kích hoạt tính năng QoS

mls qos

B2. Tạo Extended Access cho phép mọi truy cập
ip access-list extended ACL_8M
permit ip any any


B4. Tạo class map để phân loại các traffic
class-map match-all CLASS_8M
match access-group name ACL_8M

B5. Tạo Policy
policy-map POLICY_8M
class CLASS_8M
police 8000000 100000 exceed-action drop interface

Trong đó: 8000000 là tốc độ tính bằng bit/s, 8000000 bit/s = 8Mbps, đây là tốc độ mà bạn muốn gán cho cổng mạng.
100000 là burst size tính bằng byte, vấy đề là chọn burst size sao cho không ảnh hưởng đến hiệu suất của mạng. Thông thường độ trể cho phép của một mạng từ 1 đến 600 ms. Trong ví dụ này mình chọn đỗ trể là 50ms=0.05s, mình sẽ tính ra tốc độ burst size theo công thức như sau: burst size = 2 * (8000000bps/8) * 0.05s = 100000byte

B6. Gán Policy cho cổng mạng muốn hạn chế tốc độ
GigabitEthernet0/2
service-policy input POLICY_8M
Trong ví dụ này input là chiều đi vào cổng mạng (Client upload dữ liệu lên mạng)

Trường hợp ngược lại ouput là chiều đi ra khỏi cổng mạng (Client download dữ liệu về máy)
GigabitEthernet0/2
service-policy output POLICY_8M

Thứ Năm, 17 tháng 1, 2019

Hướng dẫn cấu hình Access-list (ACLs) trên thiết bị Cisco

Hướng dẫn nằm trong tutorial các bài hướng dẫn cấu hình thiết bị chuyển mạch switch cisco mà chúng tôi gửi tới khách hàng. Hướng dẫn cấu hình Access-list dành cho dân kỹ thuật hoặc người quản trị hệ thống mạng, chúc các bạn thành công.
Đầu tiên, có thể hiểu Access-list là một danh sách các câu lệnh được áp dụng vào các cổng interface của router hay switch cisco. Danh sách này giúp chỉ cho chúng ta thấy router hay switch sẽ biết được loại packet nào được chấp nhận hay loại bỏ. Việc chấp nhân hay loại bỏ có thể dựa vào các yếu tố như: địa chỉ nguồn, địa chỉ đích hoặc chỉ số cổng (port).

Phân loại Access-list và cách cấu hình chúng

1. Standard IP Access-list (Standard ACLs)

Đây là dòng access list chỉ lọc dữ liệu dựa vào địa chỉ IP nguồn, giá trị range của dòng này từ 1-99. Nên được áp dụng với cổng đích gần nhất, có 2 bước để cấu hình và tạo ACLs Standard:
Bước 1: Đầu tiên cần phải định nghĩa lại danh sách các ACLs để tiền hành đặt vào interface
(config)#access-list [#number] [permit | deny] [wildcard mask] [log]
Hoặc là :
(config)#access-list [#number] [permit | deny] [host | any]
Bước 2: Tiến hành đặt danh sách ACLs vào interface trên Router-Switch mà mục đích ta muốn chặn gói tin ngay tại điểm đó
(config)#interface [interface-number]
(config-if)#ip access-group [#number] [in | out]
Ví dụ demo:
(config)#access-list 1 deny 172.16.0.0 0.0.255.255
(config)#access-list 1 permit any
(config)#interface fastethernet 0/0
(config-if)#ip access-group 1 in

2. Extended IP Access - List

Đây là loại ACLs lọc dữ liệu dựa vào địa chỉ IP nguồn, đích, giao thức TCP số cổng HTTP....và các thông số windcard mask. Chỉ số range của loại ACLS nào từ khoảng 100-199, nên áp dụng cài đặt với cổng gần nguồn nhất.
Chúng ta sẽ có 2 bước để cấu hình Extended IP ACLs
Bước 1: Tạo ACLs trong chế độ cấu hình config
router(config)#access-list [#number] [permit | deny] [protocol] [wildcard mask] [source port] [destination address] [wildcard mask] [destination port] [log]
Bước 2: Áp dụng ALCs cho từng cổng theo yêu cầu ở chế độ cấu hình config-if
(config)#interface [interface-number]
(config-if)#ip access-group [#number] [in | out]
Một số chú ý trong quá trình này:
- Chế độ mặc định của tất cả các ACLs là Deny All, vậy nn trong tất cả các ACLs chúng ta tối thiểu phải có 1 lệnh permit. Và nếu trong ACLs cso cả lệnh permit và deny thì nên ưu tiên các dòng lệnh permit bên trên.
- Về hướng của ACLS khi được áp dụng vào cổng thì có thể nhớ một cách đơn giản là: In là từ host còn Out là tới host hoặc In là vào trong Router còn Out và đi khỏi Router.
- Với trường hợp xuất hiện In router thì nên kiểm tra kỹ goi tin trước khi đưa nó tới bảng xử lý, đối với Out router thì kiểm tra nó sau khi vào bảng xử lý
- Thông tin wildcard mask sẽ được tính bằng công thức
wildcark mask=255.255.255.255-subnet mask
- Địa chỉ 0.0.0.0 255.255.255.255=any
- Địa chỉ IP 0.0.0.0 = host ip_address (chỉ định cho từng host 1)
Ví dụ demo:
(config)#access-list 101 deny tcp 172.16.0.0 0.0.255.255 host 192.168.1.1 eq telnet
(config)#access-list 101 deny tcp 172.16.0.0 0.0.255.255 host 192.168.1.2 eq ftp
(config)#access-list 101 permit any any
(config)#interface fastethernet 0/0
(config-if)#ip access-group 101 out

3. Cấu hình tên access-list (named ACLs) thay cho các số hiệu

(config)#ip access-list extended tgm-access (tên của access-list)
(config-ext-nacl)#permit tcp any host 192.168.1.3 eq telnet
(config)#interface fastethernet 0/0
(config-if)#ip access-group tgm-access out

4. Permit hoặc Deny Telnet sử dụng Standard Acl

(config)#access-list 2 permit 172.16.0.0 0.0.255.255
(config)#access-list 2 deny any
(config)#line vty 0 4
(config-line)#password cisco
(config-line)#login
(config-line)#ip access-class 2 in

5. Kiểm tra và xoá Access-list (ACLs)

- Hiển thị tất cả ACLs đang sử dụng
(config)#show running-config
- Xem ACLs hoạt động trên interface nào đó
(config)#show interface [#number]
- Xem việc đặt và hướng đi của ip ACLs
(config)#show ip interfaces [#number]
- Xem những câu lệnh ACLs
(config)#show access-list [#number]
- Hiển thị tất cả ip ACLs
#show ip access-list
- Hiển thị ip ACL 101
#show ip access-list 101
- Xóa bộ đếm (to clear the counters use)
(config)#show access-list [#number]
(config)#clear access-list counter [#number]
- Xóa Access list
(config)#no ip access-list [standard-extended][#number]
(config)#interface [interface-number]
(config-if)#no access-list [#number] [permit deny] [wildcard mask]

6. Một số port thông dụng

——————————————————————–
Port Number ——-TCP port names —-UDP port names
——————————————————————–
6 ———————-TCP————————————–
21———————-FTP————————————–
23 ———————TELNET——————————–
25 ———————SMTP————————————
53———————————————-DNS————-
69 ———————————————TFTP————-
80 ———————WWW———————————–
161 ——————————————–SNMP———–
520 ——————————————–RIP————
Trên đây là bài viết hướng dẫn và chia sẻ tới khách hàng 2 dạng Access list phổ biến trên Router -Switch Cisco và cách cầu hình chúng. Khách hàng cần tham khảo kỹ bài viết trước khi tiến hành cấu hình Access-lisst để đạt hiệu quả cao nhất mà không bị lỗi. Xin cám ơn!

Thứ Hai, 14 tháng 1, 2019

Tặng em ... bạn bầu



Ba trăm sáu mươi lăm ngày
Bốn mùa trọn ở trong này .... em ơi
Mỗi ngày - riêng một nụ cười
Mỗi mùa - trăm đóa hoa tươi, ngát nồng.

Em ơi, mỗi sớm mai hồng
Đón niềm vui mới, tươi dòng thời gian
Tháng ngày, hạnh phúc, bình an
Bạn bầu - vạn dặm quan san .... vẫn gần !

Bài Thơ Tháng Một



Năm mới về với những niềm vui
Tôi muốn viết bài thơ nồng nàn tháng một
Bởi xuân sẽ về sau ngày lành tháng tốt
Cho những ngày đẹp nhất trong năm

Tháng một dịu dàng đào nở muôn nơi
Những cánh nhỏ e ấp chiều đông lạnh
Mưa nhè nhẹ vương nụ hồng lấp lánh
Như mắt người con gái nhớ thương ai.

Tháng một bồi hồi, xao xuyến lòng tôi
Những chuyến tàu đi, đợi ngày đón tết
Sân ga nhỏ lắng nghe lời từ biệt
Nhũng vui buồn, nước mắt mãi đầy vơi.

Tôi nhớ về những ngày tháng xa xôi
Tháng một trong tôi luôn nồng nàn đến thế
Xin chúc mọi người tháng một nhiều vui vẻ
Để xuân về ấm áp mãi không thôi...

Thứ Ba, 4 tháng 12, 2018

Nồi tròn lại úp vung tròn



“Nồi tròn lại úp vung tròn”
Nồi méo vung méo em còn ngại chi
Ta không phú quý lưu li
Thành tâm sống với những gì ta mơ

Thú vui chén rượu cuộc cờ
Thú vui hoa nở “khi chờ trăng lên”
Bước qua phú quý sang hèn
Chẳng vì sớm nắng, chớ phiền muộn mưa

Chúng mình phẩm hạnh đủ vừa
Không sợ sao lặn trăng mờ đêm thâu
Chắp vần điệu lí qua cầu
Kẻo mai hối hận tiếc câu thơ tình